Any way to override syntax error highlighting in code?

I’m using CM as an editor for ASP.NET-like code. In ASP.NET you create repeating items like ULs or Tables using a Header/ItemTemplate/Footer approach where ItemTemplate is the part that is repeated. As a result, opening and closing tags can be split between the Header and the Footer templates, resulting in CM showing syntax errors (see image)

Is there a way I can override this behavior in specific situations like this. I don’t want to turn of syntax checking completely.


I’ve added a matchClosing option to the xml mode in the code on github.

1 Like

Thanks marijn. I can’t wait to put it to use.