CM6: Cannot delete next line if atomic widget is at the end of line

If atomic widget (Decoration.replace + PluginField.atomicRanges by view plugin) is present at the end of line, the next line cannot be deleted.

For instance, you have lines look like


(The <widget> is the atomic widget, and | is caret.)

Then, pressing delete (backspace for windows) is not working. Nothing happen.

@codemirror/state 0.19.1
@codemirror/view 0.19.4
macOS 10.15.2
Google Chrome 92.0.4515.159


You don’t seem to be binding any command to backspace. That’ll cause various kinds of flakiness. Adding the default or standard keymap seems to solve this problem.

Oh I didn’t know that. Thank you!

However, adding the keymap solved the probrem but it seems to have caused another problem.
It seems that deleting the next character of the atomic widget also deletes the atomic widget itself.

For instance:


then pressing backspace deletes line break and <widget> too.


Thanks again!

That was a bug. This patch should address it.

It’s solved perfectly! Thanks so much!!