completions - ignore the first character

I’m writing a custom autocomplete override
this override might autocomplete string literals
Screenshot 2021-10-19 at 20.59.18

The obvious thing seemed to be to get the token at the current position.
If the token is a "String" token, then the CompletionSource's to value would be the token's to value.
i.e. after the string literal rather than where the cursor currently is.

This works well enough except with empty strings.
Empty string didn’t show any completion options.
My understanding is that the fuzzymatch is ignoring the completions for an empty string because the 2 characters '' aren’t sufficient to be considered a match.
Whereas I’d like an empty string to match everything in my list of string literal completions.

I hope that makes sense.
I wasn’t sure where to look next with this one.