How to disable autocomplete on CodeMirror 6?

How do I hide/disable/prevent that autocomplete widget from showing? I am using react codemirror.

Don’t include autocompletion sources in your configuration. Which often means, instead of including the whole support package for your programming language, only include the parser (for example javascriptLanguage instead of javascript()).

1 Like

This seems to make the CMD+A “select all” feature not work, is that correct? Or maybe I have a bug somewhere else. If correct, how can I disable autocomplete and not get rid of all the other keyboard shortcuts?

2024-02-08 22.57.53

Sounds like you removed basicSetup from your configuration as well. That’s not what I suggested.